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Introduction

Introduction

Form Designer is a visual designing tool that allows the
rapid building of front-end data entry and label printing
applications.

It includes features such as:

• Label and printer type selection

• Print preview

• Page and Printer settings

• Database connections

• Multiple Screen/Form application

• Pre-defined values and data control

The layout

Form Designer’s layout is easy to use reducing the time
necessary to familiarize yourself with the software.  It
includes a Menu bar, a Tool bar, a Tool box, a Properties
grid, a Main window and a Status bar..
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The Menu bar The Menu bar comprises itself of 6 items: File, Edit, View,
Data, Layout and Help.  When clicked, each item will
expand showing a new list of items, to allow the user to
perform a variety of functions.  To access the menu items
more quickly, press Alt + the underlined letter from your
desired choice: Alt+F will open the File menu. 

The Tool bar The Tool bar is usually displayed just below the Menu bar.
It is made up of icons which represent the most commonly
used software functions.  These icons can be clicked to
quickly access these functions.

The Tool box The Tool Box is made up of the 12 controls that can be
added to a form: Label, Link label, Button, TextBox,
CheckBox, GroupBox, ListBox, ComboBox, DataGrid,
DatabaseGrid, PictureBox, Preview.

New 

Open

Save

Copy

Cut

Delete

Paste

Undo

Redo

Snap
to Grid

Align

Space
Evenly

Bring to
Front

Send 
to Back
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Each control serves a special purpose. They can be linked
to fixed or variable data and can be associated with actions.
To insert a control into your form; simply click on the control
and drag and drop it into the form.     

Control Description

Label non-active text used to show the
name of a input field

LinkLabel active text used to link to a webpage
or other specific location

Button an active control used to perform set
functions/actions

TextBox data entry field

CheckBox a control used to activate/deactivate
or select/deselect predefined features

GroupBox non active box placed around  a
group of controls for visual
organization

ListBox displays a list of data as defined in its
properties

ComboBox displays a drop-down list of data as
defined in its properties

Datagrid displays pre-defined data in a grid
such as variable names, values or
customized data
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The Properties 
Grid

The Properties Grid lists all the properties for the selected
control.  Here you can change the characteristics of your
controls such as control name, color, size, actions...  It is
context sensitive, so the list of properties will change
according to the control selected.  Having the grid displayed
replaces the usual right-click menu command. 

The Main 
Window

The Main window, displayed in the center, is your work
area.  Here, you will add controls and create the forms you
will use to input data for label printing.  Once the form has
been created and configured, you can go to View >
Execution  to run the form and see its final result.

DatabaseGrid displays the database defined in the
properties along with some basic
functionalities such as filters and
search fields.

PictureBox a box where an image can be
imported into

Preview a box that will display a preview of the
label attached to the form

Control Description
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The Status bar The Status bar gives you the x axis and y axis location of
your pointer, the form name and the name and basic details
of the control you have selected.

The Basics

What are 
Actions?

Actions are functions that are assigned to buttons and to
load/unload forms.  In Form Designer, 12 pre-defined
Actions have been included in the Actions menu to save you
time and to eliminate the need for programming. In some
cases, where specific parameters must be configured,
these, too, have been pre-defined in the Action’s
configuration.

The pre-defined Actions are:.

MAIN WINDOW

Actions Show the document property dialog box

Displays the properties dialog box for the
selected document which shows information
such as creation date and its location.

Action Show the form dialog box

Displays the form dialog box where the user
can set the values for the form variables
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Action Show the options dialog box

Displays an options dialog box where you
can, for instance, change the display
language and other settings.

Action Show the printing dialog box

Displays the print dialog box where you print
from.  Here, you can also set the number of
labels printed and see a preview of the print
job among other things.

Action Show the printer selection dialog box

Displays a dialog box showing a list of all of
the possible printers to print from.

Action Show the printer settings dialog box

Displays the printer settings dialog box
where settings can be set

Action Show the page setup dialog box

Displays the page setup dialog box where
the user can set label size,  page size, margin
size...

Action Print

Allows the user to print. 

Parameters Label Quantity   

Sends the printer the number of labels to be
printed.  If the document includes a counter,
the counter increments along with the
number of labels.
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Label Copy 

Lets the printer know how many identical
copies of each label should be printer

Inter Cut 

Lets the printer know how many labels to
print before each cut.

Page Copy

Lets the printer know how many copies of
each page to print

Action Select printer

Allows the user to print from the selected
printer and override any printers that may be
associated with the document. 

Parameter  Printer 

Allows you to set a printer as the default
printer to use when the button is clicked, or to
use the printer selected from a list - if a printer
selection variable is used and defined in the
form properties

Action Show CODESOFT

Allows the user to launch CODE-SOFT for
label editing.  

Parameter Show

Launches and displays CODESOFT

Action Load a new form.

Allows the user to open a new form. 

Parameters File name 

Links an xmf file to the action
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New Window

 Opens the chosen file in a new window if set
to true

Action Execute a VB Script

Allows the user to execute a user-defined VB
Script that can perform actions beyond the
Form Designer’s capabilities.  This gives the
user greater flexibility. 

Parameters File name 

Links a vbs file to the action 

Synchronous 

Synchronizes the VB Script with Form
Designer
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Creating a form

The designing

Designing forms is easy with Form Designer.  All controls
can be added to a form by way of drag and drop, then
configured in the properties grid to set color, text, action...

To show you how to create a form, we will reproduce 2
examples:  the DBF.xmf form and the Generic.xmf form.

Example 1

:
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 DBForm.xmf This simple form includes a Database Grid where you can
quickly view, change or add data in your database. 

•  Placing the 
controls

For this example, you will need to drag and drop the
following controls:

• 2 Labels
• 1 TextBox
• 1 ComboBox
• 1 Database Grid
• 1 Preview
• 2 Buttons

Place the items as in the following diagram.

•  Setting the control 
properties (no data)

With Form Designer, it is easy to set your control properties
since the Properties grid is displayed on the right-hand side
of your screen.  If you do not see the Properties Grid, go to
View > Properties grid. 

When you select a control in your form, the associated list of
properties will be displayed in the Properties Grid.

1  Set the Label propertiesas follows:

•  Name: lblLabelNumber
•  Contents > Type: Fixed Contents
•  Contents > Value: Number your Labels:
•  Font name: MS Sans Serif
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•  Font size: 8,25
•  Font Bold: True

•  Name: lblPrinter
•  Contents > Type: Fixed Contents
•  Contents > Value: Printer:
•  Font name: MS Sans Serif
•  Font size: 8,25
•  Font Bold: False

2 Set the Preview properties as follows:

• Name: prvPreview
• Contents > Type: Fixed Contents
• Contents > Value: Preview

3 Set the Database Grid properties as follows:

• Name: dbgDatabase
• Contents > Type: Fixed contents
• Contents > Value: DataBaseGrid

4 Set the Text box properties as follows:

• Name: txbQty

5 Set the Combo Box properties as follows:

• Name: cbxPrinter

6 Set the Button properties as follows:

• Name: btnPrint
• Contents > Type: Fixed Contents
• Contents > Value: Print

and the second button as: 

• Name: btnPortal
• Contents > Type: Fixed contents
• Contents > Value: Back to Portal

•  Setting the control 
properties (with 
data)

Some of the controls require more than just setting text
properties.  Buttons require actions, grids require data,
boxes require variables.  The next few steps will walk you
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through these controls, their properties and configurations.

Setting the Database grid’s properties

A Database grid allows the user to view a pre-selected
database.  A selected row will display the associated label
in the preview box.  The user can Add, Delete, Filter and
Search for information with the Database grid.

• Database > Connection: select  Batcher from the drop-
down menu 
• Database > Table: Select Print Job from the drop
down menu

Note

In Database > Connection, you can select from an 
existing list of linked databases or add a new one.  The 
latter will take you to the ‘Add Database Connection’ 
wizard.

Setting the Form’s properties

Although the form does not appear in the ToolBox, it, too, is
a control to be configured.  In fact, for certain controls, such
as datagrids or listboxes, where data can be linked, the
Form acts as the base, and requires specific parameters to
be set in order for the data controls to be functional.

• Attached label: Identity.lab
• Variables: 7 variables should have automatically filled
in this field.  The 7 variables are the label variables
received from the label’s attached database. However,
two Form variables must also be added to use with the
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print button to set the label’s default printer as the one
be used for printing and to state the number of labels
printed.  

To add these new variables:

1  Click on the down-arrow from the Variables field.

2 In the section titled Form Variables,  click Add

3 Type-in Printer and OK

4 Repeat steps 2 and 3 for Qty

When you return to the Form properties grid, you will notice
that you now have 9 variables.

Setting the Text box’s properties

This TextBox is used to tell the printer how many label
copies it must print.  The number entered in the textbox by
the user defines the number of copies. If a counter is present
on the label, the counter will be incremented with each label
copy. To set the properties:

• Contents > Type: Variable contents
• Contents > Value: select Qty from the drop-down list
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(this variable was created in the form properties)

Setting the Combo box’s properties

The ComboBox is used to select a printer from the
predefined list. To set the properties:

• Contents >Type: Variable contents
• Contents > Value: select Printer from the drop-down
list (this variable was created in the form properties)
• Data > Type: Printers
• Data > Value > Printers type: select THT

Setting the Buttons’ properties

Buttons not only require the standard text properties such as
Name and Font,  they also require an action.  Form Designer
has included, in its Button properties grid, an action field that
allows you to pick from a standard list of actions.  These
actions have been created and predefined for the ease of
the user, eliminating the need for complex programming and
reducing the possibility of errors. 

1  Click on the Print button (btnPrint)

2 Go to Actions and click the  button.  A dialog box
appears

3 Click Add

4 In Description, click the down-arrow and choose Select
printer. One parameter must be defined.
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5 Click on parameters.  A new dialog box appears. 

6 Set  Type as Variable

7 Set Value as Printer (which you can select from a drop
down list... Printer is the form variable created in the form
properties). Click OK

8 Back in the original Actions window, click Add

9 Under  Various > Description, click the down-arrow and
choose Print. Four parameters must be defined.

• Label Quantity: set Type as Variable and Value as
Qty (this variable can be selected from a drop-down
list... it is the variable created in the form properties)
• Label Copy: leave with default settings
• Inter Cut: leave with default settings
• Page Copy: leave with default settings

10 Click OK

The Print button has been configured to print the number of
labels as defined by the user in txbQty.  The label’s counter
will be incremented accordingly (if appllicable).

1  Click the Back to Portal button (btnPortal)
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2 Click on the  button.  A new dialog box appears

3 Go to Various > Description and select Load new form
from the drop-down menu.  2 parameters must be defined.

• File Name: set Type as Fixed and Value as
MainMenu.xmf
• New Window: set Type as Fixed and leave Value
empty

The Back to Portal button has been configured to open the
MainMenu.xmf form where the user can select a printer and
access the page setup, the printer settings and printer
management
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Example 2

Generic.xmf This form allows you to see some of the more advanced
features of Form Designer.  It lets you choose a label from a
list, view its data variables, preview your label, choose how
many label copies you would like printed as well as
configure and select the printer to be used. 

•  Placing the 
controls

For this example, you will need to drag and drop the
following controls:

•  3 labels
•  1 link label
•  1 picture box
•  3 buttons
•  1 textbox
•  1 listbox
•  1 combo box
•  1 group box
•  1 preview
•  1 datagrid
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Place the items as in the following diagram:

•  Setting the control 
properties (no data)

When you select a control in your form, the associated list of
properties will be displayed in the Properties Grid.

1  Set the label properties as follows:

•  Name: lblSelect
•  Contents > Type: Fixed Contents
•  Contents > Value: Select your label:
•  Font name: MS Sans Serif
•  Font size: 8,25
•  Font Bold: True

•  Name: lblPrinter
•  Contents > Type: Fixed Variables
•  Contents > Value: Printer:
•  Font name: MS Sans Serif
•  Font size: 8,25
•  Font Bold: True

•  Name: lblQty
•  Contents > Type: Fixed Contents
•  Contents > Value: Label Quantity:
•  Font name: MS Sans Serif
•  Font size: 8,25
•  Font Bold: True

2 Set the Picture box properties as follows:

•  Name: picTeklynx
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•  Image File Name: Teklynx.jpg ( clicking on the down-
arrow will open a dialog box: Select Fixed and locate the
image in the Icons folder of you software’s directory)
•  Alignment: TopCenter
•  Stretch Mode: OriginSize

3 Set the LinkLabel properties as follows:

•  Name: llblTeklynx
•  Contents > Type: Fixed Contents
•  Contents > Value: Teklynx.com
•  Font Name: MS Sans Serif
•  Font Size: 8,25
•  Font Bold: False
•  Navigate URL: http://www.teklynx.com

4 Set the GroupBox properties as follows:

• Name: gbxPreview
• Contents > Type: Fixed Contents
• Contents > Value: Preview

5 Set the Button properties as follows:

• Name: btnSetting
• Contents > Type: Fixed Contents
• Contents > Value: Settings
• Image File Name: pagesetup.bmp

• Name: btnPrint
• Contents > Type: Fixed Contents
• Contents > Value: Print

• Name:  btnPortal
• Contents > Type: Fixed Contents
• Contents > Value: Back to Portal

6 Set the Preview properties as follows:

• Name: prvLabel

7 Set the ListBox properties as follows:

• Name: lbxLabels
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8 Set the TextBox properties as follows:

• Name: tbxQty

9 Set the ComboBox properties as follows:

• Name: cbxPrinters

10 Set the DatagridBox properties as follows:

• Name: dgdVariables

•  Setting the control 
properties (with 
data)

Setting the Buttons’ properties

1  Click on the Settings button (btnSettings)

2 Go to Actions and click the  button.  

A dialog box opens.

3 Click on Add

4 Under Various > Description, click on the down-arrow
and select Show the printer selection dialog box

5 Click OK

The Settings button has been configured to open a dialog
box where the user can select a printer to print to that may
be different from those available in the dropdown
ComboBox (to configure, see Setting the ComboBox
properties )

1  Click the Print button (btnPrint)

2 Go to Actions and click the  button.

A dialog box opens.

3 Click on Add

4 Under Various > Description, click on the down-arrow
and select Print.  Four parameters must be defined.

5 Under Various > Parameters, click on the  button
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• Label Quantity: leave with default settings
• Label Copy: leave with default settings
• Inter Cut: leave with default settings
• Page Copy: leave with default settings

6 Click OK

The Print button has been configured to print the selected
label.  The parameters set make it so that the there is only
one page copy of the print job and that the number of label
copies corresponds to the number defined by the user .

1  Click on the Settings button (btnSettings)

2 Go to Actions and click the  button.  

A dialog box opens.

3 Click on Add

4 Under Various > Description, click on the down-arrow
and select Load a new form

5 Under Various > Parameters, click on the  button

6 Under Various

• Name: File Name
• Type: Fixed
• Value: MainMenu.xmf
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7 Repeat steps 6 : name it New Window and set its value
as True

8 Click OK

The Back to Portal button has been configured to open the
MainMenu.xmf file which allows the user to select a printer,
change its settings, manage printers, modify the page setup
and navigate to other forms.

Setting the form properties

 For the purpose of this example, you will notice that there is
a listbox which displays a list of labels.  Therefore, it can be
said that there is a Label Selection variable since there is
no fixed, attached label.

There are also 2 other variables required in this form:  the
Printer Selection variable which is selected from the drop-
down combobox, and the Label Quantity variable, which
the user defines in the textbox as being the number of label
copies he would like printed. 

To set the Form variables:

1  Click on the down-arrow in the Variables field of the
form’s property grid

A dialog box appears

2 Under Form Variables, click Add
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3 Type-in Label Selection

4 Repeat steps 2 and 3 for Printer Selection and Label
Quantity

These variables will be required when configuring the
ListBox, the TextBox and the ComboBox.

As mentioned earlier, there is no fixed attached label.
However, a label must be attached, anyway. To do so:

1  Click on the down-arrow in the Attached label field of the
form’s properties grid

A dialog box appears.

2 Select Variable since we do not want to attached a
specific label

The dialog box changes to show the list of Form variables
that have just been set.

3 Select the Label Selection variable and click OK

Setting the ListBox properties

The ListBox is used to display a list of all of the .lab labels
that can be selected for printing.  To configure, you must
select the location from which the list of labels is coming
from, and define the contents as variable, since they will
change along with your selection.  To do so:

1  In the properties grid, click on Contents > Type and
define it as Variable

2 Click on Contents > Value and define it as Label
Selection

3 Click on Data > Type and select directory. The information
in the ListBox will come from a specific directory

4 Click on the down-arrow in Data > Value > Folder 

A dialog box appears
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5 Select fixed and locate the Label folder in  your software’s
directory

6 Click OK

7 Under Data > Value > Filter, type-in *.lab to select all .lab
files present in the Label folder, regardless of their name

Setting the ComboBox properties

The ComboBox is used to select a printer from the
predefined list. To set the properties:

1  Click on Contents > Type and define it as Variable

2 Click on Contents > Value and define it as Printer
Selection

3 Click on Data > Type and select Printers

4 Click on Data > Value > Printer type and select Windows

This will display the list of  Windows printers configured on
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the the workstation or network.

Setting the Textbox properties

This TextBox is used to tell the printer how many label
copies it must print.  The number entered in the textbox by
the user defines the number of copies. If a counter is present
on the label, the counter will be incremented with each label
copy. To set the properties:

1  Click on Contents > Type and set it as Variable
contents

2 Click on Contents > Value and select Label Quantity

Setting the Preview properties

1  Click on Contents > Type and set it as Variable
contents 

This is all the configuration needed to preview the label
chosen in the listbox.

Setting the Datagrid properties

The Datagrid displays the data from the selected label along
with its variable names. To set its properties:

1  Click on Contents > Type and set as Fixed contents

2 Click on Data  and set it as Table

3 Click on Data > Type and set as Label variables
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4 Click on Data > Table > Title and set it as Please enter
data

Once you have followed all these steps, go to View >
Execution or press F4 to execute your form and test that
everything works properly.


