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BACKTRACK® Version 5.0 
 

BACKTRACK 5.0 asset and inventory tracking software offers new 
features and device support that make it easier than ever to track the 
exact location, movement and usage of any item accurately and 
efficiently.  

BACKTRACK 5.0 delivers fixes and corrections and support for new 
devices that have been added since the release of version 4.5. This 
release note documents the features and corrections made in version 5.0. 

New Features 
 

• Added Database Support - Backend database support now includes 
Microsoft SQL Server 2000, SQL Server 2005, SQL Express 2005 and 
Microsoft Access, in addition to existing support for Microsoft Visual 
FoxPro. 

• New Mobile Device Support - In addition to continuing support for 
legacy DOS-based portable data terminals (PDTs), support has been 
added for several new Windows mobile devices (see PDT/Mobile Device 
Support section). 

• Label Designer Support - The BACKTRACK 5.0 Label Design module 
now works with all TEKLYNX label design programs (CODESOFT, 
LABEL MATRIX, LABELVIEW). The label design program is a separate 
installation on its own CD. 

Supported label design programs: 

o CODESOFT Enterprise edition, version 8.00.08 or higher 

o LABEL MATRIX PowerPro edition, version 8.00.05 or higher 

o LABELVIEW Gold edition, version 8.10.00 or higher 

• HTML Export Options - You can now export tracking data in HTML 
format. 

• Enhanced Password Protection - Updated password protection options. 

Mobile Device/PDT Support 
For the latest list of supported mobile devices and portable data terminals 
(PDTs), go to http://www.teklynx.com/backtrack/devices. 

 

The following Mobile Devices were tested with BACKTRACK 5.0: 

• PSC Falcon 4420 (Windows Mobile 5.0) 

• Symbol MC50 (Mobile PocketPC 2003, Win CE 4.1) 

• Symbol MC70 (Win CE 5.0) 

http://www.teklynx.com/backtrack/devices
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• Symbol PPT8800 (Mobile PocketPC 2003, Win CE 4.1) 

• Symbol MC9090 (Mobile PocketPC 2005, Win CE 5.0) 

• Teklogix Workabout Pro (Mobile PocketPC 2003, Win CE 4.2) 

• Unitech HT660 (Win CE 5.0) 

• Unitech PA600 (Windows Mobile 5.0) 

• Unitech PA960 (Win CE 4.2) 

 

Mobile Devices - Supported Operating Systems/Processors 

• Windows CE .NET 4.1 

• Windows CE .NET 4.2 

• Windows Mobile 2003 

• Windows Mobile 2003 SE 

• Windows Mobile 5.0 (with some restrictions; see Prerequisites 
listed below for more information) 

• Any Windows mobile device with an ARM processor, including 
MIPs, Hitachi SuperH (SH3, SH4) and Intel x86 processors 

 

Prerequisites for Windows Mobile Devices:   
For mobile devices driven by Windows CE higher than version 4.2 SE 
(4.2 .Net, CE 5, Mobile 5 and so on), in order for the sync process to work 
properly with BACKTRACK, you must upgrade the device settings using 
the following steps: 

1. Install Microsoft .NET Compact Framework 2.0 on the device. It can 
be downloaded from the Microsoft web site: 

http://www.microsoft.com/downloads/details.aspx?familyid=0c1b0a88-
59e2-4eba-a70e-4cd851c5fcc4  

2. Install the ADOCE 3.1 drivers. The cab file for the ADOCE setup can 
be found at: 

http://www.nlpark.com/supportfiles.aspx  
   
For Symbol devices, download the CAB file for the ARM processor 
(http://www.nlpark.com/downloads/ADOCE31.ARM.CAB ), copy it to 
the device, and start setup from the device.  
   
Note: The .NET Compact Framework must be installed before the 
ADOCE setup.  

3. Verify that the following 3 entries are present in the registry of the 
device: 

HKEY_LOCAL_MACHINE\Security\Policies\Policies\00001001 = 1  

     -> change default value from 2 to 1  
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HKEY_LOCAL_MACHINE\Security\Policies\Policies\00001006 = 1  

     -> change default value from 2 to 1  

HKEY_LOCAL_MACHINE \Security\Policies\Policies\0000101b = 1  

     -> add this key (DWORD type) if not present and set value to 1  

These registry keys must be updated on the device in order to work 
with BACKTRACK. The registry keys must be set before the 
application is programmed from BACKTRACK (i.e., program the 
application again, and then do data retrieval). 

 

Supported DOS-Based Legacy PDTs 
Note: None of the devices listed below support 2D scanning.  

• Brady DLT 8  

• Brady DLT 16  

• Compsee Apex II  

• Compsee Apex III  

• Denso BHT-5000 (32 key)  

• Denso BHT-6000 (26 key)  

• Denso BHT-7000 (32 key)  

• Denso BHT-8000 (28 key)  

• Dynasys 2001  

• Hand Held Products Dolphin 7200 Numeric keypad  

• Hand Held Products Dolphin 7200 Alphanumeric keypad  

• Opticon PHL2700  

• Opticon PHL2700 RFID  

• Percon Falcon 310  

• Percon Falcon 320  

• Percon Falcon 330  

• Seal PDT 3100 (35 key and 46 key)  

• Seal PDT 6800  

• Symbol PDT 3100 (35 key and 46 key)  

• Symbol PDT 3805  

• Symbol PDT 6800  

• Unitech PT600  

• Unitech  PT700 
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Fixes and Corrections 
 

• Fixed issue with Check Out transaction where the “Use the following data 
for all remaining items selected for check out” option was not saving with 
this check box selection as the default. 

• Fixed issue with checked out item having system quantity of 0 (correct) 
but when a physical inventory is run, it shows the item having a system 
quantity of 1, which is not correct.  

• Added ability to include the Source Location and Target Location as fields 
that can be used within reports (previously, only the Target Location was 
available). 

• Fixed issue occurring when you have “Archive Checked Out Items” 
selected and then select a Checked Out item to change the status, but 
the status was not changing. 

• Fixed issue with Custom Receipts for transactions where the selected 
report and/or label was not printing. 

• Fixed issue where the “Add duplicate new items” option was not working 
correctly for inventory applications. If specifying a quantity when adding 
duplicate items, it now adds the quantity correctly. 

Known Issues 
 

• Command Line Functionality: Command line functionality is not 
supported in version 5.0. 

• Viewing Relations and Print to .TXT File: After completing a View 
Relations transaction, if you select the option to print to a .TXT file, the 
resultant text file is empty. 

• Customized Receipts: If you have customized receipts (reports or 
labels) set up to print after transactions are completed, if you later edit the 
application using the wizard, it reverts back to printing the default receipt. 
The workaround for this issue is to reset the custom reports and/or labels 
in the Customize Receipts dialog box. 

• .XML Issue with Access as Backend Database in Win XP: Under 
Windows XP, if you are using Microsoft Access as the backend database 
type for BACKTRACK, it is not possible to import data from an .XML file. 

• No Keyed Access Database When Printing through BACKTRACK: In 
the label designer, if you have attached an external database and set it 
up to used keyed access, when you print through BACKTRACK it does 
not prompt for the key field (so keyed access will not work when printing 
through BACKTRACK). 
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• LABEL MATRIX as Label Designer - Converting Older Labels: If you 
are using LABEL MATRIX as the installed label design program and you 
have older labels that were created in a previous version of 
BACKTRACK, these labels can be converted and used in the current 
version of BACKTRACK. When you open the older labels in the current 
BACKTRACK label designer (in this case, LABEL MATRIX), the fields 
that are linked to a BACKTRACK database will have a "Database" data 
origin. In order for these fields to successfully link to the BACKTRACK 
database in the current version of the software, you will need to edit each 
field and change its origin to "Keyboard Input." (See the BACKTRACK 
User's Guide or online Help for information on setting up LABEL MATRIX 
fields for mapping.) Once the fields’ data origins have all been changed to 
Keyboard Input, then all you need to do is map the label fields to the 
corresponding fields in the BACKTRACK database. (See the 
BACKTRACK User's Guide or online Help for information on mapping 
label fields to BACKTRACK fields.) 

• Mobile Devices Configuration: See the “Mobile Device/PDT Support” 
section for a listing of prerequisites for Windows mobile devices. 

• RemoteLink Add-On Module: The RemoteLink add-on module is for use 
only with DOS-based legacy PDTs. In order to use an older RemoteLink 
installation with BACKTRACK 5.X, you will need to copy the RemoteLink 
executable (RemoteLink.exe file) and protection libraries to the older 
version folder and then run the newly updated RemoteLink.exe file. 

1. View the contents of the BACKTRACK 5.X CD using Windows 
Explorer. 

2. Browse to the CD’s Software > RemoteLink 5.0 Upgrade folder and 
copy all files and folders contained within the RemoteLink 5.0 
Upgrade folder. 

3. Now browse to the older RemoteLink installation folder and paste all 
files into this folder. You will be asked if you want to replace files – 
click Yes. 

4. Once the paste operation is complete, the files have been 
successfully updated. Run the newly updated RemoteLink.exe file to 
use the updated RemoteLink program with BACKTRACK 5.X. (Note: 
If the Activation Wizard appears, you will need to enter a new 
RemoteLink activation code.) 

• Network Client Error with Access and Visual FoxPro Installs: If 
installing a Network Client with Access or Visual FoxPro selected as the 
database type, the following error may appear during installation: "Error 
1706. No valid source could be found for product BACKTRACK 5.0. The 
Windows Installer cannot continue." In most cases, this error occurs if 
setup is run from a network location and the user does not have full 
read/write/execute permissions on this location, or if setup is run from a 
removal media drive.  

This is actually an InstallShield error and does not affect your 
BACKTRACK installation. The workaround is to copy the Setup.exe file to 
a local drive and run the install from a local drive instead of a 
network/removable drive. 
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More information on this issue can be found on the following InstallShield 
and Microsoft Web sites: 

http://support.installshield.com/kb/view.asp?articleid=Q107140  

http://support.microsoft.com/kb/299803/ 

 

• Network Setup Issues Under Win 2000 Server, Win XP or Win Server 
2003 
For a Network Setup with the BACKTRACK Full version running on a 
computer under Windows 2000 Server, Windows XP, or Windows Server 
2003, the Network version (network client) computer may receive an 
“Unable to load license libraries…” error on startup. 

To provide access to the license libraries you must configure security 
Permissions and DCOM settings on the computer that is running the 
BACKTRACK Full version. Once you have done this using the 
appropriate steps below, then go to the computer where the Network 
version will be installed and run the BACKTRACK setup program. Then 
on the Select Network Location step, browse to select the shared Full 
version folder. 

Note: The steps below vary depending on the platform and if running 
under Windows Domain or Windows Workgroup. 

 

If the Full version computer is running under Windows XP or 
Windows Server 2003:  
1. From the Windows main menu click Start, then Control Panel, and 

then Windows Firewall. The Windows Firewall dialog box appears. 

2. If the Firewall is turned on: 

a. On the Exceptions tab, ensure that the File and Printer Sharing 
check box is selected. 

b. Click Add Program, then click Browse and select the 
TkxCnxBt.exe file in the BACKTRACK root folder. Click OK. 

c. Click Add Port, enter any name in the Name field (for example, 
DCOM Port) and 135 in the Port number field, and then click OK. 

d. Click OK to close the Firewall window and apply changes. 

 

If both the Full version and Network version computers are 
members of Windows domain: 
1. Log on to the computer that is running BACKTRACK Full version 

under an account that has Local Administrator privileges. 

2. Ensure that the BACKTRACK root folder is shared and the Network 
user account has Full Control sharing and security permissions on it. 

a. In Windows Explorer, locate and select the BACKTRACK root 
folder in the folders tree. 

http://support.installshield.com/kb/view.asp?articleid=Q107140
http://support.microsoft.com/kb/299803/
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b. If the computer is running under Windows XP, ensure that the Use 
simple file sharing option is NOT set for BACKTRACK root folder 
– in Windows Explorer choose Tools > Folder Options from the 
menu, click on the View tab, scroll to the bottom and clear the 
check box next to Use simple file sharing if it is checked and 
click OK. 

c. In Windows Explorer, right-click on the BACKTRACK root folder 
and choose Properties. Click on the Sharing tab and select the 
Share this folder option if it is not already selected. 

d. Click the Permissions button. If the name of the user that is 
running the Network version is not present in the permissions list, 
click the Add button and type in the user name that is running the 
BACKTRACK Network version, and then click OK. 

e. Ensure that the Full Control permissions check box is selected 
for the Network user account and click OK. 

f. Click on the Security tab and repeat the steps d and e, and then 
click OK to apply changes. 

 

If the Full version computer is running under Windows XP or Windows 
Server 2003: 

1. Click Start, then Run in the Windows main menu, type dcomcnfg 
and press ENTER. The Component Services window appears. 

2. In Component Services, expand Component Services, expand 
Computers, and then expand My Computer. 

3. On the toolbar, click the Configure My Computer button. The My 
Computer dialog box appears. 

4. In the My Computer dialog box, click the COM Security tab. 

5. Under Launch and Activation Permissions, click Edit Limits. The 
Launch Permission dialog box appears. 

6. Click the Add button, in the field Enter the object names to select, 
type the user name that is running the BACKTRACK Network version 
(use the Check Names button for validation or Advanced button for 
search), then click OK. 

7. Under Permissions for <User> (where <User> is the name of the 
Network version user that you have just added), select the Remote 
Launch and Remote Activation check boxes, and then click OK. 

8. Under Launch and Activation Permissions, click Edit Default. The 
Launch Permission dialog box appears. 

9. Repeat step 5-6 for this dialog box. 

10. Click OK to apply changes and close the My Computer dialog box. 
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If the Full version computer is running under Windows 2000: 

1. Click Start, then Run in the Windows main menu, type dcomcnfg 
and press ENTER. The Distributed COM Configuration Properties 
window appears. 

2. Click the Default Security tab. 

3. Under Default Access Permissions, click the Edit Default button. 

4. In the Registry Value Permissions window, click the Add button, 
type in the user name that is running the BACKTRACK Network 
version, and click OK twice. 

5. Under Default Launch Permissions, click the Edit Default button. 

6. Repeat step 4 and click OK to close the Distributed COM 
Configuration Properties window and apply changes. 

 

If both the Full version and Network version computers are 
members of Windows workgroup: 
Before installing the BACKTRACK Network version, on the Full version 
computer you must first create the Windows user account under the 
Network version that will be used to access the Full version folder. 

1. Log on to the computer that is running the BACKTRACK Full version 
under the account that has Local Administrator privileges. 

2. Click Start, then Run in the Windows main menu, type lusrmgr.msc 
and press ENTER. Local Users and Groups window opens. 

3. In the Local Users and Groups (Local) tree select the Users node, 
then select Action > New User from the menu. The New User dialog 
box appears. 

4. Enter the same User name and set the same Password as the 
account under which the network user logs into the Network version 
computer, clear the User must change password at next logon 
check box if it is selected, and then click Create. 

5. Ensure that the BACKTRACK root folder is shared and the Network 
user account that you created in step 4 has Full Control sharing and 
security permissions on it: 

a. In Windows Explorer, locate and select the BACKTRACK root 
folder. 

b. If the computer is running under Windows XP, ensure that the Use 
simple file sharing option is NOT set for the BACKTRACK root 
folder – in Windows Explorer, choose Tools > Folder Options 
from the menu, click on the View tab, scroll to the bottom clear the 
check box next to Use simple file sharing if it is checked and 
click OK. 

c. In Windows Explorer, right-click the BACKTRACK root folder and 
choose Properties. Click on the Sharing tab and select the 
Share this folder option if it is not already selected. 
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d. Click the Permissions button. If the name of the user that is 
running the Network version is not present in the permissions list, 
click the Add button and type in the user name that is running the 
BACKTRACK Network version, and then click OK. 

e. Ensure that the Full Control permissions check box is selected 
for the Network user account and click OK. 

f. Click on the Security tab and repeat steps d and e, then click OK 
to apply changes. 

 

If the Full version computer is running under Windows XP or Windows 
2003 Server: 

1. Click Start, then Run in the Windows main menu, type dcomcnfg 
and press ENTER. The Component Services window appears. 

2. In Component Services, expand Component Services, expand 
Computers, and then expand My Computer. 

3. On the toolbar, click the Configure My Computer button. The My 
Computer dialog box appears. 

4. In the My Computer dialog box, click the COM Security tab. 

5. Under Launch and Activation Permissions, click Edit Limits. The 
Launch Permission dialog box appears. 

6. Click the Add button, in the field Enter the object names to select 
type in the user name that is running the BACKTRACK Network 
version (use the Check Names button for validation or Advanced 
button for search), then click OK. 

7. Under Permissions for <User> (where <User> is the name of the 
Network version user that you have just added), set the Remote 
Launch and Remote Activation check boxes, and then click OK. 

8. Under Launch and Activation Permissions, click Edit Default. The 
Launch Permission dialog box appears. 

9. Repeat steps 2-3 for this dialog box. 

10. Click OK button to apply changes and close the My Computer dialog 
box. 

 

If the Full version computer is running under Windows 2000: 

1. Click Start, then Run in the Windows main menu, type dcomcnfg 
and press ENTER. The Distributed COM Configuration Properties 
window appears. 

2. Click the Default Security tab. 

3. Under Default Access Permissions, click the Edit Default button. 

4. In the Registry Value Permissions window, click the Add button, 
type in the user name that is running the BACKTRACK Network 
version, and click OK twice. 
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5. Under Default Launch Permissions, click the Edit Default button. 

6. Repeat step 1 and click OK to close the Distributed COM 
Configuration Properties window and apply changes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright 2007 Braton Groupe sarl.  All rights reserved.  TEKLYNX and BACKTRACK are 
registered trademarks of Braton Groupe sarl or its affiliated companies.  All other brands 
and product names are the trademarks of their respective owners. 

This release note is for informational purposes only. Product specifications are likely to 
change. 
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